Refacola Installieren: Unterschied zwischen den Versionen

Aus Eclipse
Wechseln zu: Navigation, Suche
(Installation)
Zeile 22: Zeile 22:
 
*** <code>de.feu.ps.refacola.api</code>
 
*** <code>de.feu.ps.refacola.api</code>
 
*** <code>de.feu.ps.refacola.solvers</code>
 
*** <code>de.feu.ps.refacola.solvers</code>
** Hilfsplugin zum Moggen von Faktenbasen mittels Textdateien
+
** Hilfsplugin zum Mocken von Faktenbasen mittels Textdateien
 
*** <code>de.feu.ps.refacola.factbase</code>
 
*** <code>de.feu.ps.refacola.factbase</code>
 
* Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt <code>de.feu.ps.refacola.dsl</code> die Datei <code>de\feu\ps\refacola\dsl\GenerateRefacola.mwe2</code> ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
 
* Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt <code>de.feu.ps.refacola.dsl</code> die Datei <code>de\feu\ps\refacola\dsl\GenerateRefacola.mwe2</code> ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
Zeile 28: Zeile 28:
 
* Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
 
* Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
 
* Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im <code>src</code>-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im <code>src-gen</code>-Ordner.
 
* Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im <code>src</code>-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im <code>src-gen</code>-Ordner.
* Damit das Moggen von Faktenbasen per Textdateien genutzt werden kann, muss ebenso im Projekt <code>de.feu.ps.refacola.factbase</code> der <code>GenerateFactBase.mwe2</code>-Workflow ausgeführt werden.
+
* Damit das Mocken von Faktenbasen per Textdateien genutzt werden kann, muss ebenso im Projekt <code>de.feu.ps.refacola.factbase</code> der <code>GenerateFactBase.mwe2</code>-Workflow ausgeführt werden.

Version vom 14. November 2012, 15:04 Uhr

Die Refacola ist eine domänenspezifische Sprache, mit welcher constraintbasierte Refaktorisierungswerkzeuge erstellt werden können. Sie basiert auf XText und ist mitsamt Editor und Compiler als Eclipse-Plugin implementiert.

Installation

  • Nach Installation von Eclipse muss das Xtext SDK installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
  • Benötigt werden folgende Projekte aus trunk/refacola/core
    • Plugins für Refacola-Editor, und -Assistenten
      • de.feu.ps.refacola.dsl
      • de.feu.ps.refacola.dsl.ui
      • de.feu.ps.refacola.dsl.ui.project
      • de.feu.ps.xtext
    • Code zum generieren von Refactoring-Tools
      • de.feu.ps.refacola.generator
    • APIs für die generierten Refactoring-Tools
      • de.feu.ps.refacola.api
      • de.feu.ps.refacola.solvers
    • Hilfsplugin zum Mocken von Faktenbasen mittels Textdateien
      • de.feu.ps.refacola.factbase
  • Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
  • Die vier Projekte/Plugins für Refacola-Editor, und -Assistenten sollten nun keine build-Fehler mehr haben. Um diese Plugins auch in Eclipse nutzen zu können, müssen sie als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> ... -> die vier exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben oder auch direkt den Export-Pfad auf das Eclipse-Verzeichnis setzen).
  • Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
  • Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im src-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im src-gen-Ordner.
  • Damit das Mocken von Faktenbasen per Textdateien genutzt werden kann, muss ebenso im Projekt de.feu.ps.refacola.factbase der GenerateFactBase.mwe2-Workflow ausgeführt werden.