Refacola Installieren: Unterschied zwischen den Versionen

Aus Eclipse
Wechseln zu: Navigation, Suche
Zeile 7: Zeile 7:
 
* Nach Installation von Eclipse muss das Xtext SDK installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
 
* Nach Installation von Eclipse muss das Xtext SDK installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
  
* Um auf das Refacola-SVN zuzugreifen, empfiehlt sich eine SVN-Anbindung wie z.B. [http://subclipse.tigris.org/ Subclipse] (Update site: [http://subclipse.tigris.org/update_1.8.x http://subclipse.tigris.org/update_1.8.x]
+
* Um auf das Refacola-SVN zuzugreifen, empfiehlt sich eine SVN-Anbindung wie z.B. [http://subclipse.tigris.org/ Subclipse] (Update site: <code>[http://subclipse.tigris.org/update_1.8.x http://subclipse.tigris.org/update_1.8.x]</code>)
  
* Die Refacola-Projekte finden sich in einem SVN unter [https://brunelleschi.fernuni-hagen.de/clare https://brunelleschi.fernuni-hagen.de/clare] (Benutzername und Kennwort auf Anfrage)
+
* Die Refacola-Projekte finden sich in einem SVN unter <code>[https://brunelleschi.fernuni-hagen.de/clare https://brunelleschi.fernuni-hagen.de/clare]</code> (Benutzername und Kennwort auf Anfrage)
 
+
* Benötigt werden folgende Projekte aus trunk/refacola/core
+
  
 +
* Benötigt werden folgende Projekte aus <code>trunk/refacola/core</code>
 
** Plugins für Refacola-Editor, und -Assistenten
 
** Plugins für Refacola-Editor, und -Assistenten
 
*** <code>de.feu.ps.refacola.dsl</code>
 
*** <code>de.feu.ps.refacola.dsl</code>
Zeile 18: Zeile 17:
 
*** <code>de.feu.ps.refacola.dsl.ui.project</code>
 
*** <code>de.feu.ps.refacola.dsl.ui.project</code>
 
*** <code>de.feu.ps.xtext</code>
 
*** <code>de.feu.ps.xtext</code>
 
 
** Code zum generieren von Refactoring-Tools
 
** Code zum generieren von Refactoring-Tools
 
*** <code>de.feu.ps.refacola.generator</code>
 
*** <code>de.feu.ps.refacola.generator</code>
 
 
** APIs für die generierten Refactoring-Tools
 
** APIs für die generierten Refactoring-Tools
 
*** <code>de.feu.ps.refacola.api</code>
 
*** <code>de.feu.ps.refacola.api</code>
 
*** <code>de.feu.ps.refacola.solvers</code>
 
*** <code>de.feu.ps.refacola.solvers</code>
 
+
** Hilfsplugin zum Moggen von Faktenbasen mittels Textdateien
* Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
+
*** <code>de.feu.ps.refacola.factbase</code>
 
+
* Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt <code>de.feu.ps.refacola.dsl</code> die Datei <code>de\feu\ps\refacola\dsl\GenerateRefacola.mwe2</code> ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
* Die vier Projekte/Plugins für Refacola-Editor, und -Assistenten sollten nun keine build-Fehler mehr haben. Um diese Plugins auch in Eclipse nutzen zu können, müssen sie als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> ... -> die vier exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben oder auch direkt den Export-Pfad auf das Eclipse-Verzeichnis setzen).
+
* Die vier Projekte/Plugins für Refacola-Editor, und -Assistenten sollten nun keine build-Fehler mehr haben. Um diese Plugins auch in Eclipse nutzen zu können, müssen sie als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> ... -> die vier exportierten <code>jar</code>-Dateien in das plugin-Verzeichnis von Eclipse verschieben oder auch direkt den Export-Pfad auf das Eclipse-Verzeichnis setzen).
 
+
 
* Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
 
* Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
 
+
* Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im <code>src</code>-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im <code>src-gen</code>-Ordner.
* Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im src-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im src-gen-Ordner.
+
* Damit das Moggen von Faktenbasen per Textdateien genutzt werden kann, muss ebenso im Projekt <code>de.feu.ps.refacola.factbase</code> der <code>GenerateFactBase.mwe2</code>-Workflow ausgeführt werden.

Version vom 13. November 2012, 14:08 Uhr

Die Refacola ist eine domänenspezifische Sprache, mit welcher constraintbasierte Refaktorisierungswerkzeuge erstellt werden können. Sie basiert auf XText und ist mitsamt Editor und Compiler als Eclipse-Plugin implementiert.

Installation

  • Nach Installation von Eclipse muss das Xtext SDK installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
  • Benötigt werden folgende Projekte aus trunk/refacola/core
    • Plugins für Refacola-Editor, und -Assistenten
      • de.feu.ps.refacola.dsl
      • de.feu.ps.refacola.dsl.ui
      • de.feu.ps.refacola.dsl.ui.project
      • de.feu.ps.xtext
    • Code zum generieren von Refactoring-Tools
      • de.feu.ps.refacola.generator
    • APIs für die generierten Refactoring-Tools
      • de.feu.ps.refacola.api
      • de.feu.ps.refacola.solvers
    • Hilfsplugin zum Moggen von Faktenbasen mittels Textdateien
      • de.feu.ps.refacola.factbase
  • Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
  • Die vier Projekte/Plugins für Refacola-Editor, und -Assistenten sollten nun keine build-Fehler mehr haben. Um diese Plugins auch in Eclipse nutzen zu können, müssen sie als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> ... -> die vier exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben oder auch direkt den Export-Pfad auf das Eclipse-Verzeichnis setzen).
  • Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
  • Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im src-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im src-gen-Ordner.
  • Damit das Moggen von Faktenbasen per Textdateien genutzt werden kann, muss ebenso im Projekt de.feu.ps.refacola.factbase der GenerateFactBase.mwe2-Workflow ausgeführt werden.