Refacola Installieren: Unterschied zwischen den Versionen

Aus Eclipse
Wechseln zu: Navigation, Suche
Zeile 3: Zeile 3:
 
== Installation ==
 
== Installation ==
  
* Benötigt werden die [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/junosr1 Eclipse Modeling Tools, Juno Release]
+
* Benötigt werden die [http://www.eclipse.org/downloads/packages/eclipse-modeling-tools/junor Eclipse Modeling Tools, Juno Release 4.2.0]
  
* Nach Installation von Eclipse muss XText installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
+
* Nach Installation von Eclipse muss das Xtext SDK installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
  
* Um auf das Refacola-SVN zuzugreifen, empfiehlt sich eine SVN-Anbindung wie z.B. [http://subclipse.tigris.org/ Subclipse] (update site: [http://subclipse.tigris.org/update_1.8.x http://subclipse.tigris.org/update_1.8.x]
+
* Um auf das Refacola-SVN zuzugreifen, empfiehlt sich eine SVN-Anbindung wie z.B. [http://subclipse.tigris.org/ Subclipse] (Update site: [http://subclipse.tigris.org/update_1.8.x http://subclipse.tigris.org/update_1.8.x]
  
 
* Die Refacola-Projekte finden sich in einem SVN unter [https://brunelleschi.fernuni-hagen.de/clare https://brunelleschi.fernuni-hagen.de/clare] (Benutzername und Kennwort auf Anfrage)
 
* Die Refacola-Projekte finden sich in einem SVN unter [https://brunelleschi.fernuni-hagen.de/clare https://brunelleschi.fernuni-hagen.de/clare] (Benutzername und Kennwort auf Anfrage)
Zeile 13: Zeile 13:
 
* Benötigt werden folgende Projekte aus trunk/refacola/core
 
* Benötigt werden folgende Projekte aus trunk/refacola/core
  
** a
+
** Plugins für Refacola-Editor, und -Assistenten
** b
+
*** <code>de.feu.ps.refacola.dsl</code>
 +
*** <code>de.feu.ps.refacola.dsl.ui</code>
 +
*** <code>de.feu.ps.refacola.dsl.ui.project</code>
 +
*** <code>de.feu.ps.xtext</code>
  
* Um aus der Refacola-Grammatik, den Templates und der Implementierung der Refacola Typprüfung den Code für Refacola-Compiler und Editor zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow")
+
** Code zum generieren von Refactoring-Tools
 +
*** <code>de.feu.ps.refacola.generator</code>
  
* Die Projekte de.feu.ps.refacola.dsl, de.feu.ps.refacola.dsl.ui und de.feu.ps.refacola.dsl.ui.project sollten nun fehlerfrei kompilieren
+
** APIs für die generierten Refactoring-Tools
 +
*** <code>de.feu.ps.refacola.api</code>
 +
*** <code>de.feu.ps.refacola.solvers</code>
  
* Um einen Refacola-Editor und Assistenten zur Erstellung von Refacola-Projekten zu generieren, müssen diese drei Projekte als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> die drei exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben).
+
* Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
  
* Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können.
+
* Die vier Projekte/Plugins für Refacola-Editor, und -Assistenten sollten nun keine build-Fehler mehr haben. Um diese Plugins auch in Eclipse nutzen zu können, müssen sie als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> ... -> die vier exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben oder auch direkt den Export-Pfad auf das Eclipse-Verzeichnis setzen).
 +
 
 +
* Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
 +
 
 +
* Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im src-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im src-gen-Ordner.

Version vom 13. November 2012, 11:54 Uhr

Die Refacola ist eine domänenspezifische Sprache, mit welcher constraintbasierte Refaktorisierungswerkzeuge erstellt werden können. Sie basiert auf XText und ist mitsamt Editor und Compiler als Eclipse-Plugin implementiert.

Installation

  • Nach Installation von Eclipse muss das Xtext SDK installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
  • Benötigt werden folgende Projekte aus trunk/refacola/core
    • Plugins für Refacola-Editor, und -Assistenten
      • de.feu.ps.refacola.dsl
      • de.feu.ps.refacola.dsl.ui
      • de.feu.ps.refacola.dsl.ui.project
      • de.feu.ps.xtext
    • Code zum generieren von Refactoring-Tools
      • de.feu.ps.refacola.generator
    • APIs für die generierten Refactoring-Tools
      • de.feu.ps.refacola.api
      • de.feu.ps.refacola.solvers
  • Um den Code für Refacola-Editor und -Assistenten zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow"; dass im Projekt (noch) Fehler existieren, kann ignoriert werden)
  • Die vier Projekte/Plugins für Refacola-Editor, und -Assistenten sollten nun keine build-Fehler mehr haben. Um diese Plugins auch in Eclipse nutzen zu können, müssen sie als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> ... -> die vier exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben oder auch direkt den Export-Pfad auf das Eclipse-Verzeichnis setzen).
  • Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können. Nach Erstellung eines solchen Projekts sollte sich direkt ein Editor öffnen, der eine Beispiel-Refacola mit Syntax-Highlighting darstellt.
  • Um aus dem Beispiel den Refactoring-Code zu generieren, muss die mwe2-Datei im src-Ordner des Plugins als mwe2-Workflow ausgeführt werden. Der generierte Code findet sich anschließend im src-gen-Ordner.