Refacola Installieren: Unterschied zwischen den Versionen

Aus Eclipse
Wechseln zu: Navigation, Suche
(Die Seite wurde neu angelegt: „Die Refacola ist eine domänenspezifische Sprache, mit welcher constraintbasierte Refaktorisierungswerkzeuge erstellt werden können. Sie basiert auf XText und…“)
 
Zeile 10: Zeile 10:
  
 
* Die Refacola-Projekte finden sich in einem SVN unter [https://brunelleschi.fernuni-hagen.de/clare https://brunelleschi.fernuni-hagen.de/clare] (Benutzername und Kennwort auf Anfrage)
 
* Die Refacola-Projekte finden sich in einem SVN unter [https://brunelleschi.fernuni-hagen.de/clare https://brunelleschi.fernuni-hagen.de/clare] (Benutzername und Kennwort auf Anfrage)
 +
 +
* Benötigt werden folgende Projekte aus trunk/refacola/core
 +
 +
** a
 +
** b
 +
 +
* Um aus der Refacola-Grammatik, den Templates und der Implementierung der Refacola Typprüfung den Code für Refacola-Compiler und Editor zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow")
 +
 +
* Die Projekte de.feu.ps.refacola.dsl, de.feu.ps.refacola.dsl.ui und de.feu.ps.refacola.dsl.ui.project sollten nun fehlerfrei kompilieren
 +
 +
* Um einen Refacola-Editor und Assistenten zur Erstellung von Refacola-Projekten zu generieren, müssen diese drei Projekte als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> die drei exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben).
 +
 +
* Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können.

Version vom 13. November 2012, 10:30 Uhr

Die Refacola ist eine domänenspezifische Sprache, mit welcher constraintbasierte Refaktorisierungswerkzeuge erstellt werden können. Sie basiert auf XText und ist mitsamt Editor und Compiler als Eclipse-Plugin implementiert.

Installation

  • Nach Installation von Eclipse muss XText installiert werden ("Help" -> "Install Modelling Components" -> XText auswählen -> "Finish" -> ... )
  • Benötigt werden folgende Projekte aus trunk/refacola/core
    • a
    • b
  • Um aus der Refacola-Grammatik, den Templates und der Implementierung der Refacola Typprüfung den Code für Refacola-Compiler und Editor zu generieren, muss im Projekt de.feu.ps.refacola.dsl die Datei de\feu\ps\refacola\dsl\GenerateRefacola.mwe2 ausgeführt werden (Rechtsklick -> "Run As" -> "MWE2 Workflow")
  • Die Projekte de.feu.ps.refacola.dsl, de.feu.ps.refacola.dsl.ui und de.feu.ps.refacola.dsl.ui.project sollten nun fehlerfrei kompilieren
  • Um einen Refacola-Editor und Assistenten zur Erstellung von Refacola-Projekten zu generieren, müssen diese drei Projekte als Plugins exportiert und in Eclipse eingebunden werden (Markieren -> Rechtsklick -> "Export..." -> "Deployable plug-ins and fragments" -> die drei exportierten jar-Dateien in das plugin-Verzeichnis von Eclipse verschieben).
  • Nach einem Neustart von Eclipse sollte sich unter "File" -> "New" -> "Other..." ein Eintrag "Xtext" -> "Refacola Project" finden, mit dem neue Refacola-Projekte erstellt werden können.